Autor Thema: Midi Ausgabe im Frescobaldi | Ubuntu  (Gelesen 4246 mal)

himatt

  • Newbie
  • *
  • Beiträge: 3
Midi Ausgabe im Frescobaldi | Ubuntu
« am: Samstag, 18. November 2017, 19:11 »
Liebe Lilyponder,
ich bekomme die Midiausgabe mit dem in Frescobaldi integrierten Midi-Player nicht mehr in Gang. Ich weiß, dass ich mit Ubuntu 16.4 die Ports von timidity in den Midi-Einstellungen auswählen konnte. Ich erinnere mich an eine Hilfe in einem Wiki (?) zu Frescobaldi, in dem das Vorgehen beschrieben war, ich jedesmal nach Neuinstallation Ubuntu diese Hilfe fand - nunmehr unauffindbar ???
Informationen zu meinen Versuchen:
OS: Ubuntu 17.10
Lilypond 2.18, Frescobaldi 3.0.0
als Port lässt sich in den Midi-Einstellungen nur "Midi Through Port-0" auswählen
starte ich im Terminal timidity, lassen sich die Ports von timidity auswählen. (Ich möchte aber möglichst wie bisher nicht erst im Terminal Befehle eintippen ...)
Danke für die Hilfe
Himatt

Malte

  • Hero Member
  • *****
  • Beiträge: 510
Antw:Midi Ausgabe im Frescobaldi | Ubuntu
« Antwort #1 am: Sonntag, 19. November 2017, 12:04 »
Hallo Himatt,

willkommen zurück im Forum! Ich arbeite auch mit Frescobaldi 3.0.0 unter Linux (allerdings nicht Ubuntu, sondern Manjaro) und mit verschiedenen LilyPond-Versionen (die spielen aber ja für das Problem erstmal keine Rolle). Da ich gerade in den letzten Wochen immer mal wieder den MIDI-Output genutzt habe, wollte ich mich immer mal bei Gelegenheit drum kümmern.

Eine Sache, die mal funktioniert hat (hatte da noch ein anderes System): Ich hab qsynth (ein frontend zu fluidsynth) verwendet. Das mußte ich einfach mit nem Klick auf ein Icon starten (also keine Terminaleingaben nötig). Außerdem mußte ich da einmalig einstellen, daß qsynth immer den selben Port öffnen soll, damit ich den bei Frescobaldi nicht jedes Mal aufs neue starten muß. Ich frag mich, obs eine andere Möglichkeit mit fluidsynth gibt, die nicht mal ein Starten von Hand erfordert.

Falls ich was finde, melde ich mich. Ich schau auch nochmal nach timidity, hatte damals allerdings irgendeinen Grund, das nicht zu verwenden …

himatt

  • Newbie
  • *
  • Beiträge: 3
Antw:Midi Ausgabe im Frescobaldi | Ubuntu
« Antwort #2 am: Sonntag, 19. November 2017, 17:53 »
Danke Malte!
... zurück im Forum ... ja, hab lange nix gemacht mit Lilypond (unter 17.4 war Frescobaldi nicht zu gebrauchen) und wunderte mich, dass es meinen Account hier nicht mehr gab.
Man kann ja auch Befehle definieren in den Fresco-Einstellungen (Hilfsprogramme). Geht da irgendwas? Meine Eintragungen unter Midi haben bisher keinen Effekt. Oder steht diese Option für etwas ganz anderes??
Schönen Abend!